Standard Deviation
You have final scores of an examination for n students. Calculate standard deviation of the scores s1, s2 … sn.
The variance α^2 is defined by
α^2 = (∑ni=1(si – m)2)/n
where m is an average of si. The standard deviation of the scores is the square root of their variance.
Input
The input consists of multiple datasets. Each dataset is given in the following format:
n
s1 s2 ... sn
The input ends with single zero for n.
Output
For each dataset, print the standard deviation in a line. The output should not contain an absolute error greater than 10^-4.
Constraints
- n ≤ 1000
- 0 ≤ si ≤ 100
Sample Input
5
70 80 100 90 20
3
80 80 80
0
Sample Output
27.85677655
0.00000000
問題を解く
- 最简单解法,直接按公式算。
#include <stdio.h>
#include <math.h>
#include <iostream>
#include <string.h>
#include <algorithm>
#include <iomanip>
double average(double* s, int n)
{
double sum = 0;
for (int i = 0; i < n; i++)
{
sum += s[i];
}
double avg = sum / n;
return avg;
}
using namespace std;
int main() {
int n = 0;
double s[1001] = { 0 };
double t[1001] = { 0 };
while (true)
{
cin >> n;
if (n == 0) break;
for (int i = 0; i < n; i++)
{
cin >> s[i];
}
for (int i = 0; i < n; i++)
{
t[i] = pow((s[i] - average(s, n)), 2);
}
double sd = sqrt(average(t,n));
cout << fixed << setprecision(10);
cout << sd << endl;
}
}
A Good Try
- 用vector来写也许会简单很多!